< Home Get SwitchCenter FAQ Contact

System requirements

For best experience we recommend OSX 12 (Monterey).
OSX 11 (Big Sur) required.

Changelog

v1.1.2

Fixes

v1.1.1

Fixes

v1.1.0

Features

Fixes

v1.0.8

(beta)

Fixes

v1.0.7

(beta)

Features

Fixes

v1.0.6

Fixes

v1.0.5

Fixes

v1.0.0

Features


< Go back to homepage

Offbeat Port 2022